Author Topic: Odd computer archetecture setup prevents Grub from properly installing itself.  (Read 33895 times)

Offline onederer

  • Newbie
  • *
  • Posts: 13
Greetings everyone!

I have a 64 bit AMD computer that's been turning my hair gray, trying to use Grub.

(hda0) = Linux on a SATA hard drive
(hda1) = WindowsXP on a SATA hard drive


And believe it or not, I tried different arrangements with the two separate hard drives to make Grub bootloading much easier.  However, with this machine, this is the only configuration that actually works! I can't run Linux, without editing the Grub bootloader.  And the only way that I can now get access to a bootloader, is by using SGD.
Apparently, Grub was never designed to look to see if Windows is installed on a different drive.  It always expects to find Windows on /dev/hda.  But in this machine such is not the case.  It ends up that Grub doesn't know where to install itself, and on which drive to install itself.  The results are that when a Linux installation completes, everything looks normal.  No error messages.  But when one reboots, there is no Grub to be found, and only Windows boots up.  However on my last installation, I installed Sabayon's latest 64 bit version.  This time, even Windows couldn't be found.  The older version of Super Grub Disk couldn't find or boot Windows, or Linux.  So I downloaded the latest version of SGD.  This version did find my WindowsXP and Sabayon.  But I couldn't install Grub with SGD.  It doesn't create the proper parameters to boot Linux.  So now, I'm stuck to permanently boot up my system using SGD, and I have to manually edit the Grub that's displayed.  This is getting old and tiresome!

I don't poses the proper knowledge on how to permanently cure this problem.  I don't know how to permanently write a working grub bootloader for this one machine,  and where to install it properly. This is where you come in. The only thing that I can do now, is to edit the Grub produced by SGD, and to make it point to (hd1,0) as root, and (hd0,0) to boot Linux. Then the system boots up.

Can you help me by providing great details on how to accomplish this?

Cheers!

Offline adrian15

  • Administrator
  • Hero Member
  • *****
  • Posts: 833
  • Please test Rescatux and report back feedback...
    • El blog de adrian15
Greetings everyone!
Hi.
I have a 64 bit AMD computer that's been turning my hair gray, trying to use Grub.

(hda0) = Linux on a SATA hard drive
(hda1) = WindowsXP on a SATA hard drive

I suppose that you mean that you have two hard disks.

And believe it or not, I tried different arrangements with the two separate hard drives to make Grub bootloading much easier.  However, with this machine, this is the only configuration that actually works! I can't run Linux, without editing the Grub bootloader.  And the only way that I can now get access to a bootloader, is by using SGD.
Well you can boot. It's a good piece of news.


Apparently, Grub was never designed to look to see if Windows is installed on a different drive.  It always expects to find Windows on /dev/hda.
The problem is not Grub the problem is your distribution installer that does not let you map correctly bios drive and linux drive.
  But in this machine such is not the case.  It ends up that Grub doesn't know where to install itself, and on which drive to install itself.  The results are that when a Linux installation completes, everything looks normal.  No error messages.  But when one reboots, there is no Grub to be found, and only Windows boots up.
This is because Grub is installed in the hard disk that you are not booting from.

  However on my last installation, I installed Sabayon's latest 64 bit version.  This time, even Windows couldn't be found.  The older version of Super Grub Disk couldn't find or boot Windows, or Linux.  So I downloaded the latest version of SGD.  This version did find my WindowsXP and Sabayon.
I suppose it is the 256 byte inode ext3 support addition that made it work.

But I couldn't install Grub with SGD.  It doesn't create the proper parameters to boot Linux.  So now, I'm stuck to permanently boot up my system using SGD, and I have to manually edit the Grub that's displayed.  This is getting old and tiresome!

Grub gets installed, isn't it ? But the boot parametres are not ok? That's what I understand.

I don't poses the proper knowledge on how to permanently cure this problem.  I don't know how to permanently write a working grub bootloader for this one machine,  and where to install it properly. This is where you come in. The only thing that I can do now, is to edit the Grub produced by SGD, and to make it point to (hd1,0) as root, and (hd0,0) to boot Linux. Then the system boots up.
I see.
Can you help me by providing great details on how to accomplish this?

Cheers!

Well, I need to write a wiki page about this kind of problems, and I could take your example as a base.
In the meanwhile you can read this:

http://www.supergrubdisk.org/wiki/AddANewHardDisk#Grub_solution

adrian15
If you have liked this piece of advice please consider donating to the Super Grub Disk project.

Offline onederer

  • Newbie
  • *
  • Posts: 13
Thank you for the come-back.

Quote
The problem is not Grub the problem is your distribution installer that does not let you map correctly bios drive and linux drive.

This problem has happened with all the distributions that I have tried with this machine.  Using the Bios and swapping the drive postions didn't work.  Swapping the SATA wires didn't work.  Just about everything that's suggested in the link that you gave me, didn't work. An this happened when the drive was new and empty, and still does when the hard drive is loaded with an OS.  When I tried to install WindowsXP in (hd0), it just wouldn't work!  It kept on giving me strange error messages that I couldn't understand.  As a last ditch effort, I desperately installed WinXP in (hd1). and it worked perfectly.  That's how I found out about this strange machine set.  When I used Grub to map the drives differently, the same problem occured. No bootup, no installation.  I've given up. My last ditch effort is to now come to this forum to permanently end this problem.

If I don't use the SGD to boot up, all I see is Grub stage 1 scrolling up the screen.  Yes it's true I am booting up with the latest version of SGD, but I would like to be able to boot the system without having to depend on SGD, and always having to manually edit it.  This is why I'm asking your help for this.  The thing that I have to edit to make it work, I'd like to save it in Linux, so that the system would boot up without my having to worry, or lose time about it.

Offline adrian15

  • Administrator
  • Hero Member
  • *****
  • Posts: 833
  • Please test Rescatux and report back feedback...
    • El blog de adrian15
Thank you for the come-back.
You are welcome.

This problem has happened with all the distributions that I have tried with this machine.  Using the Bios and swapping the drive postions didn't work.
The fact is that after swapping drives sometimes some menu.lst and grub reinstall is needed.

Swapping the SATA wires didn't work.  Just about everything that's suggested in the link that you gave me, didn't work.

I see, but it would be better to tell what have you tried exactly.

An this happened when the drive was new and empty, and still does when the hard drive is loaded with an OS.  When I tried to install WindowsXP in (hd0), it just wouldn't work!  It kept on giving me strange error messages that I couldn't understand.  As a last ditch effort, I desperately installed WinXP in (hd1). and it worked perfectly.

hd1.... interesting.


That's how I found out about this strange machine set.  When I used Grub to map the drives differently, the same problem occured. No bootup, no installation.  I've given up. My last ditch effort is to now come to this forum to permanently end this problem.
Hummmm.

If I don't use the SGD to boot up, all I see is Grub stage 1 scrolling up the screen.  Yes it's true I am booting up with the latest version of SGD, but I would like to be able to boot the system without having to depend on SGD, and always having to manually edit it.

I assume that you have already tried: http://www.supergrubdisk.org/wiki/Howto_Fix_Grub#Classical_solution

But did you try this same option after running EASY LIVE SWAP at the first screen?

http://www.supergrubdisk.org/wiki/SGD_Quick_Menu#EASY_LIVE_SWAP


  This is why I'm asking your help for this.  The thing that I have to edit to make it work, I'd like to save it in Linux, so that the system would boot up without my having to worry, or lose time about it.
Ok. Let's see. If how to fix grub with or without easy live swap does not work then you should try this:

Choose Language & Help -> English -> Advanced -> GRUB -> Restore Grub in Hard Disk (MBR) -> Manual Restore GRUB in Hard Disk (MBR) (!NO stage1_5).

Select the partition where the linux it is and then select the hard disk where you think you boot from.

If it does not work, reboot again with SGD, run EASY LIVE SWAP and repeat these same steps.

Sometimes linking directly to stage2 instead of stage1_5 does help.

Waiting for your answers. I like difficult problems.  ;)

adrian15
If you have liked this piece of advice please consider donating to the Super Grub Disk project.

Offline onederer

  • Newbie
  • *
  • Posts: 13
I'll try what you suggested.  And I'll get back to you with the results.  I don't know if you remember this but last year we had a long exchange of correspondence on this matter. I was using your regular email address.  You thought I was in France, and you stated that you were going there for a vacation?  I then informed you that I was in the USA.
I lost track with you because here, it was the hunting season, and I was out hunting every day.

What I don't know is where Grub should be installed. (hd0,0) = Linux, or (hd1,0) = Windows.  Should it be installed in which hard drive's MBR, or in a directory? Because of ignorance in this matter, I get all confused.  Whenever that Grub installation question is asked after a Linux installation, I simply have to take a guess.  I'm getting old and worse at this.  Once I'd see a functional working system with my odd setup, then I would remember it, and what to do about it. But I'm getting terrible at remembering and troubleshooting.  I guess that I no longer have much patience anymore.  I just want to be a user, and no longer a Windows/Linux mechanic.  I find it very difficult to get the exact answers that I need which pertain to this peculiar problem.  If I did, this would have been fixed a couple of years ago.  Every time that a new version upgrade of an OS gets installed, this problem keeps on creeping up.

Cheers and thanks!

Le savant n'as pas peure de demander des questions.

Offline onederer

  • Newbie
  • *
  • Posts: 13
Here's the latest!

I tried every command in the SGD CDROM.  Not a single SGD command successfully worked on it's own!  It simply cannot figure out this type of setup. I just started Sabayon  Linux again by going into the SGD's BOOT LINUX section, and manually editing and changing the "root (hd0,0)" to "root (hd1,0)", then I typed "b" to boot the OS.  And Linux came up fine.

I even tried to use the "swap drives" application.  If I remember, I kept on getting an errot 15 on that.  The "AUTO" doesn't work either.

I tried the manual command approach.
grub> find /grub/stage1 = File not found.
grub> find /boot/grub/statge1 = (hd1,0)
grub> root (hd 1,0) = File system is ext2 (it is really an ext3 partition) partition type 0x83
grub>  setup (hd 1)
     Checking if "/boot/grub/stage1" exists ... yes
     Checking if "/boot/grub/stage2" exists ... yes
     Running "embed /boot/grub/stage1 (hd1) +16p ........ (snip!)
         (hd1,0)/boot/grub/stage 2
         /boot/grub/menu.lst" ... succeeded
Done

Now, if you give the command for the SGD application to "Boot Linux", this is what is now seen:

Root (hd0,0)    note: this is still setup to reflect the assumption that               Windows is on (hd0,0).  In my case, Windows is (hd1,0).
     Filesystem type unknown, partition type 0x? (unreadable)
     Kernel /boot/kernel/genkernel x 6_64-2.6.25-sabayon-r1                                root=/dev/ram0 randisk=8192
     realboot = UUID = 6e6309c-....... etc. do lvm init = linux xrc CONSOLE = /dev/tty1 resume swap: /dev/sda2 nox acpioff ide= nodma vga=normal
ERROR 1 : Cannot mount selected partition.

Press any key to continue.

Now, if you keep everything else the same but change the first line to:
Root (hd1,0), the system will boot Linux.

I still don't know how to make that change permanently in the computer.  Can you help me on that?  I need for Grub to see "Root" as (hd 1,0).  I need for Grub to install this properly in the MBR or on a partition (you're the expert here).  I need for the proper setup to be saved in Linux's filesystem, where it should be. 

As you can see SGD will not do this automatically, and install it correctly.  We had discussed this before.  And last year, we had discussed about "dead ended" commands on the disk. When I've exhausted all the commands at the end of SGD's application(s), there is no command to "go back", again forcing me to mostly rebooting all the time.  However, the nice thing this time is that I don't have to always have to go through the "help" system to get back to where I need to be.  This does save a lot of time when very frequent booting has to be done.  Thanks!

Cheers!

Le savant n'as pa peure de demander des questions.


Offline adrian15

  • Administrator
  • Hero Member
  • *****
  • Posts: 833
  • Please test Rescatux and report back feedback...
    • El blog de adrian15
I'll try what you suggested.  And I'll get back to you with the results.  I don't know if you remember this but last year we had a long exchange of correspondence on this matter. I was using your regular email address.  You thought I was in France, and you stated that you were going there for a vacation?  I then informed you that I was in the USA.
I lost track with you because here, it was the hunting season, and I was out hunting every day.
I remember you although I haven't checked the mails yet.

What I don't know is where Grub should be installed. (hd0,0) = Linux, or (hd1,0) = Windows.  Should it be installed in which hard drive's MBR, or in a directory? Because of ignorance in this matter, I get all confused.  Whenever that Grub installation question is asked after a Linux installation, I simply have to take a guess.  I'm getting old and worse at this.  Once I'd see a functional working system with my odd setup, then I would remember it, and what to do about it. But I'm getting terrible at remembering and troubleshooting.  I guess that I no longer have much patience anymore.  I just want to be a user, and no longer a Windows/Linux mechanic.
I suppose that sometime in the future I'll write a wiki about the overall way of working of grub.

  I find it very difficult to get the exact answers that I need which pertain to this peculiar problem.  If I did, this would have been fixed a couple of years ago.  Every time that a new version upgrade of an OS gets installed, this problem keeps on creeping up.
That's the groot variable. :)
Cheers and thanks!
Le savant n'as pas peure de demander des questions.
Et oui, quelle reason!

adrian15
If you have liked this piece of advice please consider donating to the Super Grub Disk project.

Offline adrian15

  • Administrator
  • Hero Member
  • *****
  • Posts: 833
  • Please test Rescatux and report back feedback...
    • El blog de adrian15
Here's the latest!
Let's see it!

I tried every command in the SGD CDROM.  Not a single SGD command successfully worked on it's own!  It simply cannot figure out this type of setup.
There are some kind of problems that need some work from inside the linux os and cannot be solved with SGD only. (Maybe in the future with Rescatux).
I just started Sabayon  Linux again by going into the SGD's BOOT LINUX section, and manually editing and changing the "root (hd0,0)" to "root (hd1,0)", then I typed "b" to boot the OS.  And Linux came up fine.
Ok. That defines your problem.

I even tried to use the "swap drives" application.  If I remember, I kept on getting an errot 15 on that.  The "AUTO" doesn't work either.
Swap drives application, what's that?

You are going to try that, it should work for you, it does not fix your problem, but it should work for you.

  • Boot with Super Grub Disk
  • Select: EASY LIVE SWAP option.
  • DO NOT REBOOT!
  • Select: Choose Language & Help -> English -> Linux -> Boot Linux

Your linux should boot without any problem.

I still don't know how to make that change permanently in the computer.  Can you help me on that?  I need for Grub to see "Root" as (hd 1,0).  I need for Grub to install this properly in the MBR or on a partition (you're the expert here).  I need for the proper setup to be saved in Linux's filesystem, where it should be. 

As you can see SGD will not do this automatically, and install it correctly. 
No, it cannot. It seems that either you have not read the links I gave you above or you have not understood them.

We had discussed this before.  And last year, we had discussed about "dead ended" commands on the disk. When I've exhausted all the commands at the end of SGD's application(s), there is no command to "go back", again forcing me to mostly rebooting all the time. 
You are right but you know it is not intelligent to select all the SGD options blindly.

However did you notice that error 6 is ok at hard disk or file selection screens... this way you can go back in special menues when in older versions you could not.

However, the nice thing this time is that I don't have to always have to go through the "help" system to get back to where I need to be.  This does save a lot of time when very frequent booting has to be done.  Thanks!
Yes, that "no help" option and the quick menu are good improvements.

Let's see onederer I am going to write a wiki page inspired on your case and then write a post here with a link to it so that you try the steps advised to run there and then report back your results.

Now I understand your particular setup (which it is not too special :) ) and I should be able to fix it.

adrian15
If you have liked this piece of advice please consider donating to the Super Grub Disk project.

Offline adrian15

  • Administrator
  • Hero Member
  • *****
  • Posts: 833
  • Please test Rescatux and report back feedback...
    • El blog de adrian15
Let's see onederer I am going to write a wiki page inspired on your case and then write a post here with a link to it so that you try the steps advised to run there and then report back your results.
adrian15

Here you are:

http://www.supergrubdisk.org/wiki/OnedererTwoHardDisksExample

However the instructions found here might not work in your case. But we are not going to know if you do no try it!

There are some very strange setups where the hard disk boot order given to the cdrom (i.e. Super Grub Disk) is different to the hard disk boot order given to the hard disks.

If your system is so strange I will have to add an alternative solution to the wiki so that you can finally fix your problem (Now I am a bit tired :) ).

Thank you very much for patience and please report back with exactly the Super Grub Disk options that you choose (all the steps) and the screen results.

adrian15
If you have liked this piece of advice please consider donating to the Super Grub Disk project.

Offline onederer

  • Newbie
  • *
  • Posts: 13
Thanks for rolling on this with me.

Okay, I think that I screwed up.  In between the time of my last post, and your reply, I tried to do something to help myself. 

I went into /boot/grub>grub.conf, and edited every incident that had (hd 0,0) to (hd1,0).
The current results:
The system now boots up without the need for the SGD, CDROM disk.  The next thing that happens is that I get a lot of unreadeable hash on my screen.  I can see that something is happening, and can barely see some writing, but not good enough to be able to read it.  The system seems to be booting up.  All of a sudden, the screen clears up, and the boot up continues, until it gets to the console login prompt.  This is the prompt for the "local-host" login.  At the login, I can either type "root" or "onederer.  Either one is accepted.  Next, I typed in "startx".  The screen went blank, then after a while, the Nvidia logo shows up, then I'm dropped into three terminal screens.  This was quite useless, so I typed in each one of them "exit".  I wanted to get kde going.  I tried start kde= no good, then start kdm=no good.  Then just for the fun of it, I typed in simply "kdm", and kde came up.  This currently is the long way of doing it, but without the GBUB menu, Windows is not being offered.

I haven't touched the menu-lst yet. I also typed in "update-grub" after reading you post, and the command is not recognized, even as "root".

I just did a "cat menu-lst".  This is what it looks like right now.

SM-1 grub # cat menu.lst
# grub.conf generated by the Sabayon Linux Installer
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You do not have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /, eg.
#          root (hd0,0)
#          kernel /boot/kernel-genkernel real_root=UUID=76e6309c-3c29-4fcb-bbe1-fcd26d83bcb7
#          initrd /boot/initramfs-genkernel
#boot=sda
default=1
timeout=6
splashimage=(hd0,0)/boot/grub/splash.xpm.gz

title Sabayon Linux x86-64 3.5 (genkernel-x86_64-2.6.25-sabayon-r1)
   root (hd1,0)
   kernel /boot/kernel-genkernel-x86_64-2.6.25-sabayon-r1  root=/dev/ram0 ramdisk=8192 real_root=UUID=76e6309c-3c29-4fcb-bbe1-fcd26d83bcb7 dolvm  quiet  init=/linuxrc splash=silent,theme:sabayon vga=791 CONSOLE=/dev/tty1 resume=swap:/dev/sda2
   initrd /boot/initramfs-genkernel-x86_64-2.6.25-sabayon-r1

title Sabayon Linux x86-64 3.5 (genkernel-x86_64-2.6.25-sabayon-r1) (safe mode)
   root (hd1,0)
   kernel /boot/kernel-genkernel-x86_64-2.6.25-sabayon-r1 root=/dev/ram0 ramdisk=8192 real_root=UUID=76e6309c-3c29-4fcb-bbe1-fcd26d83bcb7 dolvm init=/linuxrc CONSOLE=/dev/tty1 resume=swap:/dev/sda2 nox acpi=off ide=nodma vga=normal
   initrd /boot/initramfs-genkernel-x86_64-2.6.25-sabayon-r1

title Other Operating System - Microsoft Windows
   rootnoverify (hd1,0)
   chainloader +1
title=Sabayon Linux (kernel-genkernel-x86_64-2.6.25-sabayon-r1)
   root (hd1,0)
   kernel /boot/kernel-genkernel-x86_64-2.6.25-sabayon-r1 root=/dev/ram0 ramdisk=8192 real_root=UUID=76e6309c-3c29-4fcb-bbe1-fcd26d83bcb7 dolvm  quiet  init=/linuxrc splash=silent,theme:sabayon vga=791 CONSOLE=/dev/tty1 resume=swap:/dev/sda1
   initrd /boot/initramfs-genkernel-x86_64-2.6.25-sabayon-r1



And I booted the system, with your suggestion of "EASY LIVE SWAP".  But when I got to "Boot Linux", It couldn't do it!  Again, this time, I had to manually edit Grub to show that root (1,0), was now edited to: root (0,0)


So this is my update as of the moment.  It is just not falling into place. 

Cheers!

Offline onederer

  • Newbie
  • *
  • Posts: 13
Here's the original grub-conf before I edited it:

SM-1 grub # cat grub.conf_original
# grub.conf generated by the Sabayon Linux Installer
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You do not have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /, eg.
#          root (hd0,0)
#          kernel /boot/kernel-genkernel real_root=UUID=76e6309c-3c29-4fcb-bbe1-fcd26d83bcb7
#          initrd /boot/initramfs-genkernel
#boot=sda
default=1
timeout=6
splashimage=(hd0,0)/boot/grub/splash.xpm.gz

title Sabayon Linux x86-64 3.5 (genkernel-x86_64-2.6.25-sabayon-r1)
   root (hd0,0)
   kernel /boot/kernel-genkernel-x86_64-2.6.25-sabayon-r1  root=/dev/ram0 ramdisk=8192 real_root=UUID=76e6309c-3c29-4fcb-bbe1-fcd26d83bcb7 dolvm  quiet  init=/linuxrc splash=silent,theme:sabayon vga=791 CONSOLE=/dev/tty1 resume=swap:/dev/sda2
   initrd /boot/initramfs-genkernel-x86_64-2.6.25-sabayon-r1

title Sabayon Linux x86-64 3.5 (genkernel-x86_64-2.6.25-sabayon-r1) (safe mode)
   root (hd0,0)
   kernel /boot/kernel-genkernel-x86_64-2.6.25-sabayon-r1 root=/dev/ram0 ramdisk=8192 real_root=UUID=76e6309c-3c29-4fcb-bbe1-fcd26d83bcb7 dolvm init=/linuxrc CONSOLE=/dev/tty1 resume=swap:/dev/sda2 nox acpi=off ide=nodma vga=normal
   initrd /boot/initramfs-genkernel-x86_64-2.6.25-sabayon-r1

title Other Operating System - Microsoft Windows
   rootnoverify (hd1,0)
   chainloader +1
title=Sabayon Linux (kernel-genkernel-x86_64-2.6.25-sabayon-r1)
   root (hd0,0)
   kernel /boot/kernel-genkernel-x86_64-2.6.25-sabayon-r1 root=/dev/ram0 ramdisk=8192 real_root=UUID=76e6309c-3c29-4fcb-bbe1-fcd26d83bcb7 dolvm  quiet  init=/linuxrc splash=silent,theme:sabayon vga=791 CONSOLE=/dev/tty1 resume=swap:/dev/sda1
   initrd /boot/initramfs-genkernel-x86_64-2.6.25-sabayon-r1

SM-1 grub #

Offline adrian15

  • Administrator
  • Hero Member
  • *****
  • Posts: 833
  • Please test Rescatux and report back feedback...
    • El blog de adrian15
Thanks for rolling on this with me.
You are welcome.
Okay, I think that I screwed up.  In between the time of my last post, and your reply, I tried to do something to help myself. 

I went into /boot/grub>grub.conf, and edited every incident that had (hd 0,0) to (hd1,0).
That's a good thing, I do not know if you have understood it but it seems you are fixing the problem.

The current results:
The system now boots up without the need for the SGD, CDROM disk.
The problem has been fixed!  :D
  The next thing that happens is that I get a lot of unreadeable hash on my screen.  I can see that something is happening, and can barely see some writing, but not good enough to be able to read it.  The system seems to be booting up.  All of a sudden, the screen clears up, and the boot up continues, until it gets to the console login prompt.  This is the prompt for the "local-host" login.  At the login, I can either type "root" or "onederer.  Either one is accepted.  Next, I typed in "startx".  The screen went blank, then after a while, the Nvidia logo shows up, then I'm dropped into three terminal screens.  This was quite useless, so I typed in each one of them "exit".  I wanted to get kde going.  I tried start kde= no good, then start kdm=no good.  Then just for the fun of it, I typed in simply "kdm", and kde came up.
This is Linux specific problem, I can't help you with that although I can advice you to uninstall and install kdm with emerge (emerge was the apt-get equivalent for gentoo derivatives distros).

This currently is the long way of doing it, but without the GBUB menu, Windows is not being offered.
without? What do you mean? With the grub menu Windows is not being offered maybe?

I haven't touched the menu-lst yet. I also typed in "update-grub" after reading you post, and the command is not recognized, even as "root".
grub.conf and menu.lst are the same file. (One links to the other one).

update-grub is a debian specific command. I suppose that there is a update-grub equivalent in gentoo but I do not know which it is.

I just did a "cat menu-lst".  This is what it looks like right now.

splashimage=(hd0,0)/boot/grub/splash.xpm.gz
You missed this line.
title Other Operating System - Microsoft Windows
   rootnoverify (hd1,0)
   chainloader +1
I suppose you need to edit an put the piece of code written here:
http://www.supergrubdisk.org/wiki/Howto_Boot_Windows_From_A_Second_Hard_Disk#Grub_solution__.28Normal_Windows_installation.29

And I booted the system, with your suggestion of "EASY LIVE SWAP".  But when I got to "Boot Linux", It couldn't do it!  Again, this time, I had to manually edit Grub to show that root (1,0), was now edited to: root (0,0)
Of course I told you to use it before editing menu.lst (remember that when editing grub.conf you have actually edited menu.lst too).

adrian15
If you have liked this piece of advice please consider donating to the Super Grub Disk project.

Offline onederer

  • Newbie
  • *
  • Posts: 13
Hi,

Menus.lst was not edited. only grub.conf was edited.  And to clarify things, there is NO viewable Grub menu present on any of the hard drives .  I can't choose which type of Linux that I can boot up, I can't select Windows. I can't select which way I'd like for Linux to boot up, i.e. apm or no apm, keyboard style, dma or no dma etc. With the command "startx", I now only get the hash on the screen with unreadable text mixed up with it, until it suddenly clears itself. Then I can see the rest of the boot up sequence going on. Next I get a "System logon" prompt, and then those three terminal applications which I have to "exit" out of them to get back to console prompt.

I've done a lot of reading and at this point, the more that I read, the more confused that I get (or should I say the more frustrated).  Could you please take me on baby steps to create, and install a normal looking and working Grub menu when I boot up?
Iwas hoping that editing the grub.conf would cure the problem. It didn't.  I still don't have a Grub boot loader menu to work with.  And curently, booting up without the SGD, disk, the results today were not the same as the last time.  It wouldn't accept any commands, in text mode.  If I give it a startx command, it drops me into a useless three terminal desktop, and nothing else.

I am really anxious to get to the final, and successful conclusion of this long existing problem.  In conclusion, the problem is not fixed.  There is no hard disk working Grub menu that currently exists to work with.  SGD is still needed to do an efficient bootup. The other way, it takes much longer, and my poor wife is so very confused. Without SGD the results with hard drive boot up are never the same everytime. With a standard Grub menu, when the machine is turned on, at least my wife is smart enough to use the Grub's menu to select whether she want to run Linux or Windows.  And that frees me to concentrate on other projects. She won't need my help then.

Cheers!

Le savant n'as pas peure de demander des questions.

Offline adrian15

  • Administrator
  • Hero Member
  • *****
  • Posts: 833
  • Please test Rescatux and report back feedback...
    • El blog de adrian15
While I try to reply this post please check PRIVATE MESSAGES as soon as possible.

Thank you.

adrian15
If you have liked this piece of advice please consider donating to the Super Grub Disk project.

Offline adrian15

  • Administrator
  • Hero Member
  • *****
  • Posts: 833
  • Please test Rescatux and report back feedback...
    • El blog de adrian15
Hi,

Menus.lst was not edited. only grub.conf was edited.
Why then menu.lst seems to have been edited?

  And to clarify things, there is NO viewable Grub menu present on any of the hard drives .  I can't choose which type of Linux that I can boot up, I can't select Windows.
Didn't you told me:
Quote
The system now boots up without the need for the SGD, CDROM disk.
If the system boots but you do not see Grub that means that it is splashimage problem.

Do you remember:
Quote
Quote from: onederer on 2008 23, 17, 03:23:49 AM
splashimage=(hd0,0)/boot/grub/splash.xpm.gz
You missed this line.

If you edit this line so that (hd1,0) is read instead of (hd0,0) then you will see your grub menu.

I can't select which way I'd like for Linux to boot up, i.e. apm or no apm, keyboard style, dma or no dma etc. With the command "startx", I now only get the hash on the screen with unreadable text mixed up with it, until it suddenly clears itself. Then I can see the rest of the boot up sequence going on. Next I get a "System logon" prompt, and then those three terminal applications which I have to "exit" out of them to get back to console prompt.
You might consider installing Ubuntu. :)

I've done a lot of reading and at this point, the more that I read, the more confused that I get (or should I say the more frustrated).
I am sorry about that.

Could you please take me on baby steps to create, and install a normal looking and working Grub menu when I boot up?
Try commenting (putting a # symbol at the beginning) the splashimage line.

Iwas hoping that editing the grub.conf would cure the problem. It didn't.  I still don't have a Grub boot loader menu to work with.  And curently, booting up without the SGD, disk, the results today were not the same as the last time.  It wouldn't accept any commands, in text mode.  If I give it a startx command, it drops me into a useless three terminal desktop, and nothing else.
I will try to help you with that (See PM).

I am really anxious to get to the final, and successful conclusion of this long existing problem.  In conclusion, the problem is not fixed.  There is no hard disk working Grub menu that currently exists to work with.  SGD is still needed to do an efficient bootup. The other way, it takes much longer, and my poor wife is so very confused. Without SGD the results with hard drive boot up are never the same everytime. With a standard Grub menu, when the machine is turned on, at least my wife is smart enough to use the Grub's menu to select whether she want to run Linux or Windows.  And that frees me to concentrate on other projects. She won't need my help then.
Let's see what we can do.

adrian15
If you have liked this piece of advice please consider donating to the Super Grub Disk project.